[DFTB-Plus-User] import error in dp_dos

전영인 yijhon at uos.ac.kr
Fri Feb 22 04:04:05 CET 2019


Dear Ben,


Thank you for your answer, Ben.

I've checked the installation of numpy for python 2 and 3 as follows.


[vasp at mn0 ~]$ pip3 install --user numpy
Requirement already satisfied: numpy in /usr/anaconda3/lib/python3.6/site-packages (1.16.1)
[vasp at mn0 ~]$ pip install --user numpy
Requirement already satisfied: numpy in /usr/anaconda3/lib/python3.6/site-packages (1.16.1)
[vasp at mn0 ~]$ dp_dos
Traceback (most recent call last):
  File "/home/vasp/dftb+/bin/dp_dos", line 15, in 
    import numpy.polynomial.hermite as  H
ImportError: No module named hermite


However, dp_dos still showed the error message.


What would be wrong with it?

Thank you for your answer in advance.


Best regards,

  Young





-----------------------원본메세지-----------------------
보낸사람: Ben Hourahine 
받는사람: dftb-plus-user at mailman.zfn.uni-bremen.de
보낸날짜: 2019-02-20 17:51:02 GMT +0900 (Asia/Seoul)
제목: Re: [DFTB-Plus-User] import error in dp_dos



Hello Young,

The dp_dos code requires numpy to be installed correctly for the version of python that is present on your system.




Depending on how the dp tools were installed, this could be either python2.x or python3.




You can check by finding the dp_dos and checking its top line, so for example on my system:




$ which dp_dos

/home/ben/.local/bin/dp_dos





$ head /home/ben/.local/bin/dp_dos




#!/usr/bin/python3
 #------------------------------------------------------------------------------#
 #  DFTB+: general package for performing fast atomistic simulations            #
 #  Copyright (C) 2018  DFTB+ developers group                                  #
 #                                                                              #




Regards

Ben





On 20/02/2019 03:42, 전영인 wrote:




Dear Sir,

 

I can run dftb+ without error but when I use precompiled dp_dos, the following error appeared.

 

Traceback (most recent call last):
   File "/home/vasp/dftb+/bin/dp_dos", line 15, in 
     import numpy.polynomial.hermite as  H
 ImportError: No module named hermite

 

I checked that site-packages directory is included in sys.path.

What's wrong with it?

 

Thank you for your answer in advance.

 

Best regards,

  Young

 

 

 



Research Professor

Brain Korea 21 Plus, Department of Electrical and Computer Engineering

University of Seoul, Seoul, Korea



_______________________________________________
DFTB-Plus-User mailing list
DFTB-Plus-User at mailman.zfn.uni-bremen.de
https://mailman.zfn.uni-bremen.de/cgi-bin/mailman/listinfo/dftb-plus-user

-- 
        Dr.  B.  Hourahine,  Senior  lecturer
            SUPA, Department  of  Physics,
             University  of  Strathclyde,
              John  Anderson  Building,
          107 Rottenrow, Glasgow G4 0NG, UK.                    
  +44 141 548 2325, benjamin.hourahine at strath.ac.uk

The  Department is  a partner  in SUPA,  the Scottish
            Universities Physics Alliance

The University  of Strathclyde  is a  charitable body,
       registered in Scotland, number SC015263
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://mailman.zfn.uni-bremen.de/pipermail/dftb-plus-user/attachments/20190222/e406c0b2/attachment.html>


More information about the DFTB-Plus-User mailing list