[DFTB-Plus-User] MPI Version crashes

Silvio a Beccara s.abeccara at gmail.com
Tue Sep 24 12:30:04 CEST 2013


Dear Bálint,

sorry for my late reply, I've been to a conference.
Setting aside the NAG compiler (to which we've access just on one of our 
machines) for the time being, I tried to use the gcc 4.9 (release 
20130922) compiler.

Unfortunately, I get this error message during compilation:

Cannot read module file 'mpi.mod' opened at (1), because it was created 
by a different version of GNU Fortran

I think that this has to do with the version of OpenMPI I am using: did 
you re-compile also OpenMPI from scratch with the 4.9 compiler?

Thanks

Silvio

> I agree, that dependig on Intel alone is not desirable for DFTB+. On the
> other hand, there are some features in Fortran 2003 which I'd definitely
> like to use (mostly the OOP stuff). Also, GNU Fortran is almost there!
> I've just compiled the current development snapshot of gcc 4.9 (2013901)
> and with it OpenMPI 1.6.5, Scalapack 2.0.2 and LAPACK 3.4.2. Using that
> suite, the code does compile and passes all autotests without changes in
> the code and also your example runs fine. So I am very optimistic that
> with gcc 4.9.0 we will have a stable GNU compiler being able to compile
> the parallel version.

> Could you
> eventually try to set up the gfortran 4.9 for your plattform and test
> with it? For me it worked locally.
>
>    Cheers,
>



More information about the DFTB-Plus-User mailing list