[DFTB-Plus-User] MPI Version crashes

Bálint Aradi balint.aradi at bccms.uni-bremen.de
Wed Sep 4 17:36:32 CEST 2013


Dear Silvio,

> Beside GCC we also tried the NAG compiler, with no success.
> It thus looks like we really need the Intel compiler, which we don't
> have access to right now: but that reduces the availability of DFTB+ to
> people who can (and want to) buy it.

What was the problem with NAG? It should support all features needed.
Unfortunately, I did not check the parallel version with the NAG yet, as
my quick attempt to compile OpenMPI with it failed. Can you send me any
output of your compilation with NAG to see me where it fails.
(Alternatively, did you manage to compile OpenMPI with NAG and if yes, how?)

I agree, that dependig on Intel alone is not desirable for DFTB+. On the
other hand, there are some features in Fortran 2003 which I'd definitely
like to use (mostly the OOP stuff). Also, GNU Fortran is almost there!
I've just compiled the current development snapshot of gcc 4.9 (2013901)
and with it OpenMPI 1.6.5, Scalapack 2.0.2 and LAPACK 3.4.2. Using that
suite, the code does compile and passes all autotests without changes in
the code and also your example runs fine. So I am very optimistic that
with gcc 4.9.0 we will have a stable GNU compiler being able to compile
the parallel version.

> Is it possible for you to send us an executable? The system we are
> currently running on is a 64 bit Intel cluster, with a Scientific Linux
> release 6.3 (Carbon).

Unfortunately, after spending already a considerable amount of time on
it, I am still not able to create a binary which does not depend on any
intel libraries (links them statically) but links the OpenMPI library
dynamically.

If anyone with an Intel compiler managed to achieve this, please let me
know which linking flags you've used. (Whatever I do "-static-intel",
"-Bstatic", etc. I get dependencies on libintlc.so and some other shared
libraries of Intel).

> I am also attaching our input file, to see whether it runs with your
> executable.

I tried it with r4448 and did not experience any difficulties for your
example. (Neither with ifort nor with gfortran 4.9.)

So, for the moment unfortunately we're somewhat stucked. Could you
eventually try to set up the gfortran 4.9 for your plattform and test
with it? For me it worked locally.

  Cheers,

   Bálint

-- 
Dr. Bálint Aradi
Bremen Center for Computational Materials Science, University of Bremen
http://www.bccms.uni-bremen.de/cms/people/b_aradi/


-------------- next part --------------
A non-text attachment was scrubbed...
Name: signature.asc
Type: application/pgp-signature
Size: 261 bytes
Desc: OpenPGP digital signature
URL: <http://www.dftb-plus.info/pipermail/dftb-plus-user/attachments/20130904/6e7223ef/attachment.pgp>


More information about the DFTB-Plus-User mailing list