[DFTB-Plus-User] Simulation stops, glibc related error

Bálint Aradi balint.aradi at bccms.uni-bremen.de
Mon Jan 10 09:33:18 CET 2011

Dear Puja,

> I have been running NVE simulations for the protonated water cluster (H2O)21H+ in the gas phase. I am using second order SCC-DFTB and I am running simulations at several different temperatures (I equilibrated the system to the desired temperature by an NVT simulation first). At some of the temperatures, I can run a 50 ps long simulation without any problem. However, at some temperatures, the simulation just stops at some point and I get the following error:
> *** glibc detected *** dftb+: free(): invalid pointer: 0x0000000006f96480 ***

 Seems like a bug in the memory management (e.g. array boundary problem).

> I don't think there is a problem with my executable because I have used the same executable to run many other simulations and it works fine. I also ran the autotest suite with this executable and there was 100% match. I have tried restarting the simulation from the point at which it stopped but I get the same error always. Has anyone come across a similar problem before? I would really appreciate any help regarding how to solve this problem.

 Could you please send me a complete example, so that I can reproduce
it? (E.g. the input you use for the restarting, which also fails.) Also,
could you please try it with the standard binaries to be found on the
webpage, in order to check, if our binaries produces the same?

 Thanks in advance,


Dr. Bálint Aradi
Bremen Center for Computational Materials Science, University of Bremen

-------------- next part --------------
A non-text attachment was scrubbed...
Name: signature.asc
Type: application/pgp-signature
Size: 262 bytes
Desc: OpenPGP digital signature
Url : http://www.dftb-plus.info/pipermail/dftb-plus-user/attachments/20110110/f0bff163/attachment.pgp 

More information about the DFTB-Plus-User mailing list