[DFTB-Plus-User] Simulation stops, glibc related error

Puja Goyal pgoyal at chem.wisc.edu
Sun Jan 9 22:06:06 CET 2011


I have been running NVE simulations for the protonated water cluster (H2O)21H+ in the gas phase. I am using second order SCC-DFTB and I am running simulations at several different temperatures (I equilibrated the system to the desired temperature by an NVT simulation first). At some of the temperatures, I can run a 50 ps long simulation without any problem. However, at some temperatures, the simulation just stops at some point and I get the following error:

*** glibc detected *** dftb+: free(): invalid pointer: 0x0000000006f96480 ***
======= Backtrace: =========
======= Memory map: ========
00400000-01aa9000 r-xp 00000000 00:19 571768848                          /home/pgoyal/bulk_water_final/executable/dftb+
01ca8000-01cf4000 rwxp 016a8000 00:19 571768848                          /home/pgoyal/bulk_water_final/executable/dftb+
01cf4000-01d3b000 rwxp 01cf4000 00:00 0
06c66000-06fd9000 rwxp 06c66000 00:00 0                                  [heap]
41522000-41523000 ---p 41522000 00:00 0
41523000-41533000 rwxp 41523000 00:00 0
2aaaaaaab000-2aaaaada8000 rwxp 2aaaaaaab000 00:00 0
2aac4fff9000-2aac50797000 rwxp 2aac4fff9000 00:00 0
7fff5ab6d000-7fff5abb1000 rwxp 7ffffffbb000 00:00 0                      [stack]
ffffffffff600000-ffffffffffe00000 ---p 00000000 00:00 0                  [vdso]

I don't think there is a problem with my executable because I have used the same executable to run many other simulations and it works fine. I also ran the autotest suite with this executable and there was 100% match. I have tried restarting the simulation from the point at which it stopped but I get the same error always. Has anyone come across a similar problem before? I would really appreciate any help regarding how to solve this problem.



More information about the DFTB-Plus-User mailing list